Google To OEMs: Use Holo Theme; Fail To Do So, No Market Access For You

Google Holo theme

You see what Google did there? It has taken the first step in the right direction to make sure there is some sort of consistency in the UI on Android-powered devices. At the same time, it should help ease some problems for the App Developers.

In a blog post today, Google’s Adam Powell, Android Framework engineer, said that the Holo theme, will now be a requirement for OEMs to use the Android Market. Sweet muffins! However, the manufacturer customization isn’t going anywhere. Stuff like TouchWiz, Sense, MotoBlur etc won’t be dying any time soon. Not as a result of this requirement anyway.

In Android 4.0, Holo is different. We’ve made the inclusion of the unmodified Holo theme family a compatibility requirement for devices running Android 4.0 and forward. If the device has Android Market it will have the Holo themes as they were originally designed.

However, don’t be happy already, because this is a requirement for devices running Android 4.0 and later. Not Gingerbread. Oh well.. good decision nonetheless.